Saturday, 17 August 2013


The problem with the wipers was simple to address. The wipers had got themselves stuck on the windscreen and the motor had blown the fuse. Simple to fix but the dash had to come out first.

The problem with the IACV is not that straight forward. When the car went for it's pre-test checks at GBS, Simon@GBS couldn't get the IACV to work properly. The valve itself seems to be working in that it made noises and displayed a % on the Emerald control screen that could be manually altered, but it didn't seem to have any noticeable affect on the engine.
Richard@GBS said he had fixed it when I went to pick the car up, but it has since reacted in exactly the way Simon@GBS had seen to the point where I turned it off in the ECU - which hasn't made any noticeable difference to the engine idle.

The Emerald web site states that :

Two pin Idle Air Control Valves (IACV's) - how should they be wired up?
Wire one pin on the valve to an ignition fed +12v supply.  The other side goes to pin 3 (IACV Valve channel 1) on the Emerald ECU.  In the PC software go to ECU Configuration and "Idle Air Control Valve motor options" and select 300Hz as the PWM value.  If the configuration has to be changed then click the OK button and reset the ECU by switching the ignition on and off.  Read up the map from the ECU and go to the "Idle Control" tab - press F5.  Select “motor control mode” in the top right hand corner of this screen.  Set the mode to “Fixed position manual control."  Re-program the map to the ECU.

From the "live adjustments" tab (F8), and with ignition ON, engine OFF, use the page up/page down keys to alter the motor setting.  The valve is, in effect, an air injector so you should hear the motor buzzing as you increase the IACV position above about 20%.  Note that the valve will not work at very low settings or very high settings - the normal operating range is between 30% and 70%.  You can test this before starting the engine when the valve noise should be very obvious.
Having looked at wiring Richard@GBS introduced, he has one wire to the ECU and the other to ground. Having just swapped this to positive the engine simply stops after a couple of seconds. So I put everything back to where it was so I have a working car again. After thinking about this it has occurred to me that perhaps the engine stopping was actually the right result. If the valve was actually working for the first time but closed, then this is exactly what would happen. I will try again when I have more time

Tuesday, 13 August 2013

Finally Registered

Two weeks ago Ruth@GBS sent me my registration paperwork. I haven't had time to blog the fact because I have been out driving :-). 

I've now done 250 miles getting a feel for the car and how it performs - and boy does it perform !! It's potential for speed is far greater than my skill to control it at the moment, but I'm learning with every drive how the chassis reacts to power whilst cornering, how the wind can suffocate you over 80, how the front tyres pick up anything from the road surface and hurl it in your general direction, but more importantly the forgotten thrill of an open top sports car - superb !!

There are some niggles that I will need to get around to fixing - but only when its raining. Namely the IACV is not working. I don't think it ever has worked properly. The windscreen wipers stopped working the first time they jammed on the top of the screen. Other than that all is well and running sweetly.